HPE Storage Users Group

A Storage Administrator Community




Post new topic Reply to topic  [ 8 posts ] 
Author Message
 Post subject: 3PAR 8440 and Synergy flat SAN
PostPosted: Thu Feb 18, 2021 8:19 pm 

Joined: Thu Oct 30, 2014 10:16 am
Posts: 14
Hi,

I'm setting up flat-SAN connectivity (no SAN switches involved) between a 3PAR 8440 and dual Synergy 12000. Each Synergy 12000 frame has 4 FC uplinks, each to one FC port of my 4-node 3PAR. The other Synergy has also 4 FC uplinks, each to the other FC port of each controller node.

From my Synergy systems, I can see the WWN's of my 3PAR.
But when I define hosts in 3PAR SSMC (with their correct WWN name), no connectivity shows up.

I'm not sure my 3PAR FC hosts ports are configured correctly.

First question: am I right in thinking that flat-SAN connectivity requires no special configuration or settings at the 3PAR side? (it does at the Synergy side, where you have to select direct-attached instead of fabric-attached).

Second question: please have a look at the screenshots, and tell me if my 3PAR FC ports are correctly configured. I find it strange they show as "free."

Any help greatly appreciated, thanks !


Attachments:
3par ports 2.png
3par ports 2.png [ 49.72 KiB | Viewed 182 times ]
3PAR - host paths.png
3PAR - host paths.png [ 37.39 KiB | Viewed 182 times ]
3PAR - host settings.png
3PAR - host settings.png [ 35.38 KiB | Viewed 182 times ]
Top
 Profile  
Reply with quote  
 Post subject: Re: 3PAR 8440 and Synergy flat SAN
PostPosted: Thu Feb 18, 2021 9:45 pm 

Joined: Mon Sep 21, 2015 2:11 pm
Posts: 1209
Location: Europe
On the 3PAR, the ports show as "free" until a host is detected.

Did you try and boot a server and install the FC HBA drivers?

I'm assuming you have the Flexfabric module in the synergy with FC license installed.

_________________
The views and opinions expressed are my own and do not necessarily reflect those of my current or previous employers.


Top
 Profile  
Reply with quote  
 Post subject: Re: 3PAR 8440 and Synergy flat SAN
PostPosted: Fri Feb 19, 2021 1:48 am 

Joined: Wed May 07, 2014 1:51 am
Posts: 259
In SSMC, you can choose between two connection modes for host ports: "point" (fabric connection with switches) and "loop" (fc arbitrated loop). I think you have to select "loop" for SAN-less usage.

_________________
When all else fails, read the instructions.


Top
 Profile  
Reply with quote  
 Post subject: Re: 3PAR 8440 and Synergy flat SAN
PostPosted: Fri Feb 19, 2021 5:08 am 

Joined: Thu Oct 30, 2014 10:16 am
Posts: 14
MammaGutt wrote:
On the 3PAR, the ports show as "free" until a host is detected.
Did you try and boot a server and install the FC HBA drivers?
I'm assuming you have the Flexfabric module in the synergy with FC license installed.


Servers don't have local storage, they need to boot from SAN.
Yes, VC SE 100 module is installed in Synergy, and also the FC license. The blades have 25/50 CNA adapters.

Judging from screenshot, the VC can see the WWN of the 3PAR.


Attachments:
interconnect.png
interconnect.png [ 54.5 KiB | Viewed 163 times ]
Top
 Profile  
Reply with quote  
 Post subject: Re: 3PAR 8440 and Synergy flat SAN
PostPosted: Fri Feb 19, 2021 5:11 am 

Joined: Thu Oct 30, 2014 10:16 am
Posts: 14
apol wrote:
In SSMC, you can choose between two connection modes for host ports: "point" (fabric connection with switches) and "loop" (fc arbitrated loop). I think you have to select "loop" for SAN-less usage.


Can anyone else confirm the above?

BTW I tried this but then the port goes offline, and stays that way. When trying to force it online, it stays offline.


Top
 Profile  
Reply with quote  
 Post subject: Re: 3PAR 8440 and Synergy flat SAN
PostPosted: Fri Feb 19, 2021 7:00 am 

Joined: Mon Sep 21, 2015 2:11 pm
Posts: 1209
Location: Europe
hwelvaar wrote:
apol wrote:
In SSMC, you can choose between two connection modes for host ports: "point" (fabric connection with switches) and "loop" (fc arbitrated loop). I think you have to select "loop" for SAN-less usage.


Can anyone else confirm the above?

BTW I tried this but then the port goes offline, and stays that way. When trying to force it online, it stays offline.


My understanding is that this is correct for 7k systems and not 8k systems.

_________________
The views and opinions expressed are my own and do not necessarily reflect those of my current or previous employers.


Top
 Profile  
Reply with quote  
 Post subject: Re: 3PAR 8440 and Synergy flat SAN
PostPosted: Mon Feb 22, 2021 12:20 am 

Joined: Wed May 07, 2014 1:51 am
Posts: 259
I'm not 100% sure that loop thing is correct (I think it is), but you probably have to set the host-port to loop connection as well for the setup to work.

_________________
When all else fails, read the instructions.


Top
 Profile  
Reply with quote  
 Post subject: Re: 3PAR 8440 and Synergy flat SAN
PostPosted: Tue Feb 23, 2021 9:24 am 

Joined: Thu Oct 30, 2014 10:16 am
Posts: 14
I can confirm the FC ports on 3PAR 8X00 have to be in point mode for direct attach / flat SAN. (thus not loop mode)

It's working now.

PS: To solve my problem, I had to reverse the dual path 3PAR target WWN's at the Synergy side, these were wrongly configured for both FC uplink.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 


Who is online

Users browsing this forum: Google [Bot] and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group | DVGFX2 by: Matt