HPE Storage Users Group

A Storage Administrator Community




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Resolving a ancient Snapshot
PostPosted: Thu Jun 04, 2020 2:25 pm 

Joined: Fri Feb 21, 2020 1:08 pm
Posts: 4
Ok, so here's the deal I got a 3par 7400 array almost 5-6 years ago. There were a few problems with the windows file server luns at first.. So the vendor we worked with made a snapshot or two at the time to make sure we didn't mess them up. (Later found out it was an MPIO issue, which still has never gotten resolved) any case. At the time I didn't know much about snapshots (still barely have used them)
So currently I have a
DeptBase image (not exported)
----- DeptSnapshot.0 (made 4/5/2016) volumes exported /used
|
------------- DeptSnapshot.1 (6/11/2016) not exported

Now the Snapshot.0 says it's in a remote copy group, and being copied to our other array. (I have no idea if the data on the other side is really consistent/in sync as It's never been failed over.. ) And on the other array it says the volume is a base volume, and on this one it's a snapshot..
I've been told offhandedly that the tech thinks the replicated copy of DeptSnapshot.0 only copied the data over from the DeptBase and not from the snapshot (I'm no expert but that seems dumb) lol

Any case as this is hyper sensitive data. My current plan is to create a clone of the volume, (it's only 4Tb and hopefully do it overnight or something, cut off OS IO to it during the clone) check the clone that it's mountable and looks good.

I'm starting to have concerns how fast I can do it.. And I did see something about making a clone and then having it resync the clone.. So if I understand it I could make a clone, say it takes a day or two, then take the original offline then resync to get the changes (I'm assuming this resync would be alot shorter we usually only have 20gb of data changes/day.)
I'm a little concerned about doing all of this stuff as I've only made a clone once or twice.. And never done the rest of it, keep freaking out I'll hit the wrong button and world will explode.. LOL

And this is all just so I can have a base image that I can peer motion to the Primera array...
And yes I'm pissed that the vendor left us running on a snapshot (which I didn't know about till recently, (yeah I should have checked but like they say if it ain't broke don't fix))


Top
 Profile  
Reply with quote  
 Post subject: Re: Resolving a ancient Snapshot
PostPosted: Fri Jun 05, 2020 6:55 am 

Joined: Mon Sep 21, 2015 2:11 pm
Posts: 1111
Location: Europe
Have you read the Virtual Copy technical white paper? https://h20195.www2.hpe.com/v2/getdocum ... a6-4486enw

If not, it is worth the 10 minutes it will take you.

From what I'm reading, you need to delete the DeptSnapshot.1 and promote the DeptSnapshot.0... but I'm no expert :)

If it was me, I would have made a dummy volume, presented it to a host, throw in an iso, shut down the host, take a snapshot and export the snapshot instead, throw in another iso ... and test :)

_________________
The views and opinions expressed are my own and do not necessarily reflect those of my current or previous employers.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 


Who is online

Users browsing this forum: Google [Bot] and 52 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group | DVGFX2 by: Matt