3PAR Users Group

A Storage Administrator Community




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: RHEL 7.1 + multipath 0.4.9-77.el7 + 3PAR PP problem
PostPosted: Thu Sep 05, 2019 11:06 am 

Joined: Thu Sep 05, 2019 10:48 am
Posts: 1
RHEL 7.1 + multipath 0.4.9-77.el7 + 3PAR PP
The first disk looks normal
[root@localhost ~]# multipath -ll
360002ac000000000000003f5000239b1 dm-3 3PARdata,VV
size=200G features='1 queue_if_no_path' hwhandler='1 alua' wp=rw
|-+- policy='service-time 0' prio=50 status=active
| |- 1:0:1:0 sdc 8:32 active ready running
| |- 1:0:2:0 sdd 8:48 active ready running
| |- 8:0:0:0 sdf 8:80 active ready running
| `- 8:0:2:0 sdh 8:112 active ready running
`-+- policy='service-time 0' prio=1 status=enabled
|- 1:0:0:0 sdb 8:16 active ghost running
|- 1:0:3:0 sde 8:64 active ghost running
|- 8:0:1:0 sdg 8:96 active ghost running
`- 8:0:3:0 sdi 8:128 active ghost running

but when I add second disk to RCgroup,export to host, the first disk ghost become ready
[root@localhost ~]# multipath -ll
360002ac000000000000003f5000239b1 dm-3 3PARdata,VV
size=200G features='1 queue_if_no_path' hwhandler='1 alua' wp=rw
|-+- policy='service-time 0' prio=50 status=active
| |- 1:0:1:0 sdc 8:32 active ready running
| |- 1:0:2:0 sdd 8:48 active ready running
| |- 8:0:0:0 sdf 8:80 active ready running
| `- 8:0:2:0 sdh 8:112 active ready running
`-+- policy='service-time 0' prio=10 status=enabled
|- 1:0:0:0 sdb 8:16 active ready running
|- 1:0:3:0 sde 8:64 active ready running
|- 8:0:1:0 sdg 8:96 active ready running
`- 8:0:3:0 sdi 8:128 active ready running
360002ac00000000000000435000239b1 dm-4 3PARdata,VV
size=200G features='1 queue_if_no_path' hwhandler='1 alua' wp=rw
|-+- policy='service-time 0' prio=50 status=active
| |- 1:0:1:1 sdk 8:160 active ready running
| |- 1:0:2:1 sdl 8:176 active ready running
| |- 8:0:0:1 sdn 8:208 active ready running
| `- 8:0:2:1 sdp 8:240 active ready running
`-+- policy='service-time 0' prio=1 status=enabled
|- 1:0:0:1 sdj 8:144 active ghost running
|- 1:0:3:1 sdm 8:192 active ghost running
|- 8:0:1:1 sdo 8:224 active ghost running
`- 8:0:3:1 sdq 65:0 active ghost running


Top
 Profile  
Reply with quote  
 Post subject: Re: RHEL 7.1 + multipath 0.4.9-77.el7 + 3PAR PP problem
PostPosted: Wed Sep 11, 2019 5:39 pm 

Joined: Tue Mar 29, 2016 9:32 pm
Posts: 106
Can you expand on your setup ?

1 array with 8 ports zoned from the array to the host ?
2 arrays with remote copy and peer persistence with 4 ports from each array zoned to the host ?

Can you also paste your hosts persona on the array (or arrays)
- it should be Generic-ALUA Persona 2

And also your /etc/multipath.conf file.

Looking at the output, the priorities detected for the path groups looks odd .. once you post your config it'll be easier to work out.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 


Who is online

Users browsing this forum: Google [Bot] and 27 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group | DVGFX2 by: Matt