3PAR Users Group

A Storage Administrator Community




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Failed Upgrade on 7400 3.3.1 MU1 to 3.3.1 MU2
PostPosted: Thu Dec 06, 2018 8:25 pm 

Joined: Thu May 26, 2016 7:58 am
Posts: 11
First time this has happened. I tried to upgrade from 3.3.1 MU1 to 3.3.1 MU2 and the upgrade failed complaining that the nodes do not have enough disk space to perform the upgrade. Actually node 0 didn't have enough space.

This only happens during actual upgrade all the pre-checks before hitting upgrade pass.

System is a 2 node 7400.

2018-12-01 22:24:50 EST Created
2018-12-01 22:24:51 EST Start user operation
2018-12-01 22:24:51 EST Waiting on task 694 to complete
2018-12-01 22:24:58 EST Upgrade Check Scripts on StoreServ: 180829.U015
2018-12-01 22:25:01 EST Running advanced online update from version 3.3.1.269 (MU1)+P09,P11,P18,P21,P25,P28,P31 to OS-3.3.1.410-MU2
2018-12-01 22:25:01 EST Operation initiated on array.
2018-12-01 22:26:31 EST Running pre-upgrade checks.
2018-12-01 22:28:28 EST Upgrade Check Scripts on StoreServ: 180829.U015
2018-12-01 22:28:31 EST Update exiting.
2018-12-01 22:28:31 EST Advanced online update to OS-3.3.1.410-MU2 failed.
2018-12-01 22:28:31 EST HPE 3PAR CLI Error: Update failed; HPE 3PAR CLI Response Code = COMMAND_ERROR
2018-12-01 22:28:31 EST HPE 3PAR CLI Error Details:
Required space: 6944.2MB, Available space, by node:
0: 6852.0MB, 1: 13844.6MB
Storage freespace check Failed on node 0.
2018-12-01 22:28:31 EST Operation failed.
2018-12-01 22:28:31 EST Last update error:
2018-12-01 22:27:38 EST Required space: 6944.2MB, Available space, by node:
2018-12-01 22:27:38 EST 0: 6852.0MB, 1: 13844.6MB
2018-12-01 22:27:38 EST Storage freespace check Failed on node 0.
2018-12-01 22:27:38 EST Contact your support organization.
2018-12-01 22:27:38 EST Required space: 6944.2MB, Available space, by node:
2018-12-01 22:27:38 EST 0: 6852.0MB, 1: 13844.6MB
2018-12-01 22:27:38 EST Storage freespace check Failed on node 0.


I tried booting both the nodes, running the post upgrade scripts. Check health complains that one of the batteries is charging at 43% for over a week but other than that no major issues with the array.

Everything I read online says you need HPE to fix but I dont have a contract. I heard if you have root you can log in and clean up the nodes a bit.

Any help would be appreciated.


Top
 Profile  
Reply with quote  
 Post subject: Re: Failed Upgrade on 7400 3.3.1 MU1 to 3.3.1 MU2
PostPosted: Fri Dec 07, 2018 4:18 pm 
User avatar

Joined: Tue Oct 07, 2014 8:34 am
Posts: 172
I have had the same.
The Update script U15 did not check the free Node Space.
(I post this to HPE already)

L1 Support did not understand the problem, but finally L2 support login as Root and clear some Log Files on the Nodes.

Don't know how to do this yourself without root access.
Have read here, that someone have hacked root user.


Top
 Profile  
Reply with quote  
 Post subject: Re: Failed Upgrade on 7400 3.3.1 MU1 to 3.3.1 MU2
PostPosted: Wed Dec 12, 2018 5:13 am 

Joined: Sat Feb 14, 2015 3:03 pm
Posts: 27
Ping me i can help you with your problem.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 


Who is online

Users browsing this forum: Bing [Bot] and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group | DVGFX2 by: Matt