3PAR Users Group

A Storage Administrator Community




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Upgradecage Fails leaving Firmware unknown
PostPosted: Fri Oct 12, 2018 3:55 pm 

Joined: Fri Oct 12, 2018 3:33 pm
Posts: 3
I am facing an issue, where a cage0 firmware could not be upgraded on a single cage system. Batteries are at 100%, Normal State. No hardware problem is reported.
InForm OS 3.2.1 MU3 + patches up to P80

Upgrading cage cage0 cpuA from rev 321c to revision in file /opt/tpd/fw/cage/ebod/hp_eos_canister_local_combined_v321c.gff.
Upgrading cage cage0 cpuB from rev 321c to revision in file /opt/tpd/fw/cage/ebod/hp_eos_canister_local_combined_v321c.gff.
Error: Opcode = SCCMD_DOCDB
Node = 253
Tpd error code = TE_INVALID -- Invalid input parameter
Tpd error info = Cage 0, PCM_VPD 0, Firmware download failed. Redundant battery protection unavailable at this time. PS State (self: Normal, partner: Normal), Battery State (self: Normal, partner: Normal), Battery Protection available, Retries (state: 2, verification 0, download: 0), Version: 2D9457FC, Filename: /opt/tpd/fw/cage/ebod/0984124_he764W_pcm_vpd_v5_41bef99c_slot1.gff


Top
 Profile  
Reply with quote  
 Post subject: Re: Upgradecage Fails leaving Firmware unknown
PostPosted: Mon Oct 15, 2018 12:53 pm 

Joined: Mon Jun 02, 2014 1:47 pm
Posts: 28
Location: United States
Shamman wrote:
I am facing an issue, where a cage0 firmware could not be upgraded on a single cage system. Batteries are at 100%, Normal State. No hardware problem is reported.
InForm OS 3.2.1 MU3 + patches up to P80

Upgrading cage cage0 cpuA from rev 321c to revision in file /opt/tpd/fw/cage/ebod/hp_eos_canister_local_combined_v321c.gff.
Upgrading cage cage0 cpuB from rev 321c to revision in file /opt/tpd/fw/cage/ebod/hp_eos_canister_local_combined_v321c.gff.
Error: Opcode = SCCMD_DOCDB
Node = 253
Tpd error code = TE_INVALID -- Invalid input parameter
Tpd error info = Cage 0, PCM_VPD 0, Firmware download failed. Redundant battery protection unavailable at this time. PS State (self: Normal, partner: Normal), Battery State (self: Normal, partner: Normal), Battery Protection available, Retries (state: 2, verification 0, download: 0), Version: 2D9457FC, Filename: /opt/tpd/fw/cage/ebod/0984124_he764W_pcm_vpd_v5_41bef99c_slot1.gff


When this happened to me before, I manually upgraded my cages one at a time, and eventually, everything worked out.

upgradecage cage0


Top
 Profile  
Reply with quote  
 Post subject: Re: Upgradecage Fails leaving Firmware unknown
PostPosted: Fri Oct 19, 2018 4:19 am 

Joined: Fri Oct 12, 2018 3:33 pm
Posts: 3
Thank you for reply. I have tested upgradecage cage0, however that did not make any difference. Upgradecage fails with the same error.

I have noticed though that although both batteries are charged at 100%, there is always one of the batteries flashing green, which means it is in charging state or disarmed. Sometime it is battery on the left, sometimes on the right. Not sure if this may cause the upgrade to fail..


Top
 Profile  
Reply with quote  
 Post subject: Re: Upgradecage Fails leaving Firmware unknown
PostPosted: Mon Oct 29, 2018 3:51 am 

Joined: Fri Oct 26, 2018 9:05 am
Posts: 4
Quote:
I have noticed though that although both batteries are charged at 100%, there is always one of the batteries flashing green, which means it is in charging state or disarmed. Sometime it is battery on the left, sometimes on the right. Not sure if this may cause the upgrade to fail..


Both batteries must be armed and charged. Firmware upgrade requires that, to prevent failure during firmware flash.


Top
 Profile  
Reply with quote  
 Post subject: Re: Upgradecage Fails leaving Firmware unknown
PostPosted: Fri Nov 23, 2018 5:50 am 

Joined: Fri Oct 12, 2018 3:33 pm
Posts: 3
Now after a long long time, the upgradecage finally succeeded.

It looks to me, that due to the fact the array was turned off for almost half a year waiting for its next mission, the batteries were not in a perfect shape even though the showbattery -d did report 100% charged.

I left the array turned on for 3 days and the upgrade went smoothly this time.
Thanks goes to all of you guys who responded to my question!
Highly appreciated!


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 


Who is online

Users browsing this forum: Google [Bot] and 14 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group | DVGFX2 by: Matt