HPE Storage Users Group

Scripting Failure
Page 1 of 1

Author:  robocp01 [ Fri Mar 30, 2018 10:31 am ]
Post subject:  Scripting Failure

Well it's been a while since I've been on the site. Anyway thanks to all who have helped me in the past.

Here is my issue:

I run a script on a few of our servers that run Ensemble which is an interface engine that we use on our systems. The script basically takes snapshots of LUNS that we have exported to the system after stopping and restarting the cache database. It appears that my scripts are failing now. If I run a simple script to such as the following:

@setlocal enableextensions
:: Set the hostname of the 3par storage system here
:: Set the location of the pwfile you created with "setpassword -saveonly -file"
:: Ran setpassword -saveonly -file e:\scripts\scripts.pwfile (this command saves a user and password encryted in this location.
:: Add the path of the 3PAR cli bin folder to your existing path
set PATH=C:\Program Files (x86)\3par\inform_cli_3.1.2\bin;%PATH%
::set OUTNAME=rcopylist.txt

::This will remove existing exported VLUNS prior to removal of the snapshot. This should
::occur after the previous nights backups have completed..

echo Removing previously exported VLUNS
:: This command will remove all exported LUNS to HSTSENSEMBLEP1
::command is removevlun [options] <VV|VVSet> <LUN> <n:s:p>
cli removevlun -f P2_H_DB 10 XXXXENSEMBLEP2
cli removevlun -f P2_I_WIJ 11 XXXXENSEMBLEP2
cli removevlun -f P2_J 12 XXXXENSEMBLEP2
cli removevlun -f P2_K 13 XXXXENSEMBLEP2

They now fail with the following error:

Removing previously exported VLUNS
SSL channel "sock492" error: sslv3 alert handshake failure.

A cursory google search has shown nothing. Anyone have any ideas?

Author:  natekippen [ Fri Mar 30, 2018 4:19 pm ]
Post subject:  Re: Scripting Failure

Did you upgrade recently? The CLI is no longer supported in later versions of 3par IS. Consider using ssh.

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group